Problem podczas instalacji sklepu oscommerce

Konfiguracja skryptów do prowadzenia sklepów on-line.
lukasz030581
Posty: 24
Rejestracja: 27 paź 2008, 12:09:29
Reputacja: 0
Strona na CBA.pl: http://perfekt.cba.pl
Płeć: Niewybrana
User Agent: Firefox Windows 1024x768

Problem podczas instalacji sklepu oscommerce

Postautor: lukasz030581 » 27 paź 2008, 12:42:37

witam
Pytanie do administratora (albo do osoby która może mi pomóc)

chciałbym zainstalować sklep oscommerce na cba.pl

- ściągnąłem plik instalacyjny sklepu,
- umieściłem go na serwerze
- otworzyłem stronę www.perfekt.cba.pl
- otworzył się proces instalacyjny sklepu (po lewej stronie w zielonej ramce wszystkie napisy mają koło siebie zielony ptaszek z wyjątkiem cURL który ma czerwony x, piszę o tym bo nie wiem czy ma to znaczenie)
- zmieniam w Total Commandera prawa dwóch plików configure.php w katalogach:
includes/ oraz admin/includes z 644 na 666 (według instrukcji instalacji dostępnej na stronie http://www.active24.pl/pomoc/oscommerce/)
- przechodzę dalej do następnego poziomu instalacji i wpisuje odpowiednie dane w oknach

Database Server - mysql.cba.pl
Username - perfekt_cba_pl
Password - mojehasło (administrator na pewno ma dostęp )
Database Name - perfekt_cba_pl

- przechodzę dalej wszystko się ładnie zainstalowało
- wyskakuje kolejne okno

WWW Address - http://perfekt.cba.pl/
Webserver Root Directory - /

i tutaj napotykam pierwszy błąd, wiem że w oknie Webserver Root Directory powinien być podany(tak mi się wydaje) serwer gdzie będzie sklep a tu okno jest puste nie wiem czy mam coś wpisać czy co

przechodzimy dalej

- otwiera się kolejna strona gdzie wpisuję następujące dane
Store Name - nazwa sklepu
Store Owner Name - moje imię i nazwisko
Store Owner E-Mail Address - adres email sklepu
Store Owner E-Mail Password - hasło poczty
SMTP server addres - ustawienia poczty smtp.wp.pl
Administrator Username - login do administracji
Administrator Password - moje hasło

- przechodzę dalej wyskakuje że instalacja sie udała "The installation and configuration was successful!"

- przechodzę do Total Commandera i usuwam plik instalacyjny "install"
- przywracam prawa plikom includes/ oraz admin/includes z 666 na 644

- wduszam przycisk catalog (powinien przenieść mnie do strony sklepu) albo administrationtool (powinien przenieść mnie do panelu administracyjnego)

i niestety otwiera się strona na którym widnieje napis "Unable to connect to database server!"

i na tym moja wiedza na instalacji sklepu się kończy nie mam pojęcia co źle zrobiłem albo czego nie zrobiłem

proszę o pomoc w instalacji tego sklepu, dokładnie jak mam to zrobić

dziękuję bardzo i czekam na odpowiedz pozdrawiam
Awatar użytkownika
Gromed
Przyjaciel CBA
Posty: 2990
Rejestracja: 18 kwie 2006, 12:18:45
Reputacja: 53
Lokalizacja: Toruń
Płeć: Mężczyzna
User Agent: Firefox Windows 1366x768

Re: Problem podczas instalacji sklepu oscommerce

Postautor: Gromed » 27 paź 2008, 12:47:08

wyciąg z Twojego pliku configure.php

CodeColon Select All Code

 define('DB_SERVER''');
  
define('DB_SERVER_USERNAME''');
  
define('DB_SERVER_PASSWORD''');
  
define('DB_DATABASE''');
  
define('USE_PCONNECT''false');
  
define('STORE_SESSIONS'''); 

to świadczy o jednym; podczas instalacji dane dostępu do bazy nie zostały zapisane w tym pliku; możliwe, że nie miał nadanych odpowiednich CHMODów
lukasz030581
Posty: 24
Rejestracja: 27 paź 2008, 12:09:29
Reputacja: 0
Strona na CBA.pl: http://perfekt.cba.pl
Płeć: Niewybrana
User Agent: Firefox Windows 1024x768

Re: Problem podczas instalacji sklepu oscommerce

Postautor: lukasz030581 » 27 paź 2008, 13:16:44

co mam wpisać w

Webserver Root Directory ?
synia
Posty: 2
Rejestracja: 28 paź 2008, 21:58:08
Reputacja: 0
Strona na CBA.pl: fabrykaupominkow.cba.pl
Płeć: Niewybrana
User Agent: Internet Explorer Windows 1440x900

Re: Problem podczas instalacji sklepu oscommerce

Postautor: synia » 29 paź 2008, 21:48:07

Witam.
Mam dokladnie taki sam problem i wyciąg z mojego pliku configure.php jest identyczny. Czym to może być spowodowane?? Próbowalam na CHMOD'ach 666 i 777. I to samo.
No i ponawiam pytanie co wpisać w Webserwer Root Directory?
( adres mojego sklepu www.fabrykaupominkow.cba.pl)
Awatar użytkownika
fuma
Przyjaciel CBA
Posty: 11168
Rejestracja: 01 sie 2005, 14:57:56
Reputacja: 201
Lokalizacja: z jajka niespodzianki :P
Płeć: Mężczyzna
User Agent: Opera Windows 1600x1200

Re: Problem podczas instalacji sklepu oscommerce

Postautor: fuma » 29 paź 2008, 21:58:28

sprobujcie wpisac / lub /var/www/virtual/ (z lub bez nazwy swojego konta w formie nazwakonta.cba.pl/ )
synia
Posty: 2
Rejestracja: 28 paź 2008, 21:58:08
Reputacja: 0
Strona na CBA.pl: fabrykaupominkow.cba.pl
Płeć: Niewybrana
User Agent: Internet Explorer Windows 1440x900

Re: Problem podczas instalacji sklepu oscommerce

Postautor: synia » 29 paź 2008, 22:22:03

Wielkie dzięki!
Zadziałał /var/www/virtual/nazwakonta.cba.pl
:)))
Teraz działam dalej :)
Pozdrawiam.
S.

---- EDIT ----

A i oczywiście CHMOD 777.
Pozdrawiam.

---- EDIT ----

Witam.
Mam jeszcze jeden problem. Wszystko działa i jest na razie ok. tylko nie wszystkie polskie znaki wyswietlaja mi sie poprawnie.
Co zrobić w takiej sytuacji??
Dziękuję.
lukasz030581
Posty: 24
Rejestracja: 27 paź 2008, 12:09:29
Reputacja: 0
Strona na CBA.pl: http://perfekt.cba.pl
Płeć: Niewybrana
User Agent: Firefox Windows 1024x768

Re: Problem podczas instalacji sklepu oscommerce

Postautor: lukasz030581 » 07 lis 2008, 16:11:48

dzięki bardzo zrobiłem tak

/var/www/virtual/nazwakonta.cba.pl

i działa

dziękuję i pozdrawiam
Krzysiekosse
Posty: 5
Rejestracja: 22 mar 2009, 00:16:36
Reputacja: 0
Strona na CBA.pl: tattooshop
Płeć: Niewybrana
User Agent: Firefox Windows 1280x1024

Re: Problem podczas instalacji sklepu oscommerce

Postautor: Krzysiekosse » 22 mar 2009, 00:20:22

witam, mam taki sam rroblem lecz jestem kompletnie zielony w temacie :|
mogl bym prosic o wytlumaczenie jak dla dziecka co z tym zrobic?

EDIT
nie zjazylem ze to trzeba wpisac podczas instalacji:P tyle sie glowilem a takie proste:P
arturtesterWWW
Posty: 5
Rejestracja: 05 mar 2014, 18:11:47
Reputacja: 0
Strona na CBA.pl: superbielizna.cba.pl
Płeć: Niewybrana
User Agent: Firefox Windows

Re: Problem podczas instalacji sklepu oscommerce

Postautor: arturtesterWWW » 05 mar 2014, 18:14:59

pisze jak trzeba a wyskakuje cos takiego....

There was a problem connecting to the database server. The following error had occured:

Access denied for user 'superbielizna_cba_pl'@'192.168.1.1' (using password: YES)

Please verify the connection parameters and try again.
rkd77
Admin CBA
Posty: 4170
Rejestracja: 24 maja 2009, 16:45:21
Reputacja: 115
Płeć: Niewybrana
User Agent: Chrome Linux 1024x768

Re: Problem podczas instalacji sklepu oscommerce

Postautor: rkd77 » 05 mar 2014, 18:30:32

arturtesterWWW, superbielizna_cba_pl to baza danych. W tym miejscu powinien być user sql.
Czy wiesz, że:
  • W Panelu CBA w sekcji "wsparcie" jest dedykowany system ticketów (obsługi technicznej)
  • Odpowiadamy na Forum oraz na adres mailowy obsluga(malpa)cba.pl
  • Jesteśmy również na Facebooku! Znajdź nas na facebook.com/hostingcba | cba.pl
W czym jeszcze możemy pomóc?
arturtesterWWW
Posty: 5
Rejestracja: 05 mar 2014, 18:11:47
Reputacja: 0
Strona na CBA.pl: superbielizna.cba.pl
Płeć: Niewybrana
User Agent: Firefox Windows 1280x800

Re: Problem podczas instalacji sklepu oscommerce

Postautor: arturtesterWWW » 05 mar 2014, 18:30:51

zrobiłem nie nadałem użytkownika bazy danych wcześniej ale mimo ze zainstalowałem nadal nie odpala strona i mówiąc ogólnie padłem... ktoś mi może pomóc

---- EDIT ----

rkd77 WroteColonarturtesterWWW, superbielizna_cba_pl to baza danych. W tym miejscu powinien być user sql.

cała instalacja przeszła pomyslnie wywala bład ze nie ma takiego pliku do ktorego sie odnosi instalacja nie rozumiem , po instalacji najczesciej usuwa sie katalog instal , ale to tez nie pomogło,wywala ze nie ma pliku do którego ma sie odnosic instalacja, i bądz tu madry i pisz wiersze

---- EDIT ----

jak widze wszyscy maja problem z OScommerce na CBA może jakis samouczek, bo by sie przydał toturial

---- EDIT ----

OK instalacja sie powiodła , próby uruchomienia nadal skomplikowane ... mianowicie :

Warning: I am able to write to the configuration file: /var/www/virtual/nazwa strony/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

Uwaga Ostrzeżenie: Istnieje możliwość zapisu pliku konfiguracyjnego w lokalizacji: / var / www / virtual / nazwa strony / includes / configure.php. Jest to potencjalne zagrożenie bezpieczeństwa - zmień uprawnienia dla tego pliku.


co z tym zrobić?

pytanie dwa :

Error Error: Invalid administrator login attempt.
Błąd Błąd: Nieprawidłowa próba logowania administratora.

PODAJE PRAWIDŁOWE HASŁO DO PANELU ADMINISTRACYJNEGO I PRAWIDŁOWY LOGIN : sprawdzono.... ZNA KTOS ODPOWIEDZ

---- EDIT ----

Zadanie rozwiazane , usuniecie katalogu instalacyjnego, w tym trzeba poprzez wewnetrzy FTP w PANELU CBA zmienic chmod na 444

Nadal pozostaje kwestia logowania do admina nie przyjmuje ani loginu ani hasła...
Awatar użytkownika
DeaDriam
Posty: 4023
Rejestracja: 04 lip 2011, 14:00:40
Reputacja: 123
Lokalizacja: Möglingen
Płeć: Mężczyzna
User Agent: Firefox Windows 1024x768
Kontakt:

Re: Problem podczas instalacji sklepu oscommerce

Postautor: DeaDriam » 05 mar 2014, 22:26:21

arturtesterWWW
usun cala baza bo poszla instalacja z bledami
zaloz cala baza od nowa
wyslij pliki skryptu za pomoca FILEZILLA w trybie binarnym na serwer
Ustaw chmody wg instrukcji instalacji skryptu bo to niezbedne
i zainstaluj tak jak powinno byc
arturtesterWWW WroteColonjak widze wszyscy maja problem z OScommerce na CBA może jakis samouczek, bo by sie przydał totur

nie ma ,bo majac sklep....a wsparcie na Supporcie,gdzies tu pisalem co i jak
_____________________________________________________
Nie badz pijawka-znalazles rozwiazanie problemu..podziel sie na forum!
----------------------------------------------------------------------------
SmacznY WordpresS>> http://www.przepisyzgarnka.pl <<
arturtesterWWW
Posty: 5
Rejestracja: 05 mar 2014, 18:11:47
Reputacja: 0
Strona na CBA.pl: superbielizna.cba.pl
Płeć: Niewybrana
User Agent: Firefox Windows

Re: Problem podczas instalacji sklepu oscommerce

Postautor: arturtesterWWW » 05 mar 2014, 22:56:39

wszystko juz ustawiłem tak jak powyższe pisałem sklep odpala , ale nadal nie odpala panel admina ponoc istnieja inne sposoby instalacja na superbielizna.cba.pl
według mnie to cos innego szukam w PHP... jak ktos wie to niech da znac, instalacja przeszła wiec to nie to, prawdopodobnie jakis byk w skrypcie... dam se łeb upierdzielić... musi istniec inny sposób zamiast 10krotnej instalacji

---- EDIT ----

sprawa załatwiona ... błedny (uszkodzony plik instalacyjny) polecam sciagnac pliki ze strony http://www.oscommerce.info.pl/download/ ... 2b-pl.html dzialają bezproblemu

Wróć do „OpenCart, PrestaShop”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość