.htaccess nie działa

Wszystko o HTML, XHTML, XML, CSS.
kamil_lk
Posty: 2
Rejestracja: 26 lut 2013, 14:46:33
Reputacja: 0
Płeć: Niewybrana
User Agent: Firefox Windows

.htaccess nie działa

Postautor: kamil_lk » 26 lut 2013, 14:51:02

Cześć.

Robię prostą stronkę dla znajomego. Przy tej okazji chciałem ogarnąć podstawy jak zrobić ładniejsze adresy.

A więc utworzyłem plik .htaccess o treści

CodeColon Select All Code

Options FollowSymLinks
RewriteEngine On
RewriteRule 
^([a-zA-Z\-]+)/?$ index.php?section=$[L


Na lokalu wszystko śmiga. Nie wiem jak zrobić, aby działało to również na cba.pl

Proszę o pomoc.
Venite
Obsługa CBA
Posty: 3197
Rejestracja: 18 lut 2011, 08:01:57
Reputacja: 43
Lokalizacja: Kędzierzyn-Koźle
Płeć: Mężczyzna
User Agent: Internet Explorer Windows 1440x900

Re: .htaccess nie działa

Postautor: Venite » 26 lut 2013, 16:38:04

Po RewriteEngine On dodaj nową linię z wpisem

RewriteBase /

(ukośnik na końcu też jest konieczny)
Czy wiesz, że:
  • W Panelu CBA w sekcji "wsparcie" jest dedykowany system ticketów (obsługi technicznej)
  • Odpowiadamy na Forum oraz na adres mailowy obsluga(malpa)cba.pl
  • Jesteśmy również na Facebooku! Znajdź nas na facebook.com/hostingcba | cba.pl
W czym jeszcze możemy pomóc?
kamil_lk
Posty: 2
Rejestracja: 26 lut 2013, 14:46:33
Reputacja: 0
Płeć: Niewybrana
User Agent: Firefox Windows

Re: .htaccess nie działa

Postautor: kamil_lk » 26 lut 2013, 16:46:54

Teraz coś się dzieje, tylko jeszcze nie to co chciałem.

Ogólnie struktura stron wygląda tak:

+ Strona AAA
- Strona BBB
- Strona CCC

I w przypadku, gdy chcę zastosować htacces dla strony BBB to gdzie mam wrzucić plik? Bo aktualnie znajduje się w Strona BBB.

Dodam jeszcze, że w Strona BBB w index.php mam taką linijkę:

CodeColon Select All Code

<base href="http://StronaAAA.cba.pl/StronaBBB" /> 

Wróć do „HTML, CSS”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość