Przywracanie kopii zapasowej

Konfiguracja for z rodziny phpBB.
Ian
Posty: 23
Rejestracja: 22 lip 2013, 03:10:02
Reputacja: 0
Strona na CBA.pl: hungrybutterfly.y0.pl/phpbb3
Płeć: Niewybrana
User Agent: Chrome Windows

Przywracanie kopii zapasowej

Postautor: Ian » 13 sie 2013, 09:25:16

Chciałam dobrze, wyszło źle.
Próbowałam wgrać Prime Quick Style - Switch styles from any page, za pomocą automoda. Pozmieniałam, żeby sam łączył się przez FTP i sam to wgrał.
Wyszło to:
[phpBB Debug] PHP Warning: in file [ROOT]/includes/session.php on line 1629: include(./includes/prime_quick_style.php) [function.include]: failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/includes/session.php on line 1629: include() [function.include]: Failed opening './includes/prime_quick_style.php' for inclusion (include_path='.:/opt/lib/php')

Fatal error: Call to a member function set_guest_style() on a non-object in /virtual/hungrybutterfly.y0.pl/phpbb3/includes/session.php on line 1630

Nie mogę nic zrobić przez panel Admina na stronce, jedynie co to przez phpMyAdmin, ale nie mam pojęcia jak przywrócić kopię zapasową, którą wcześniej zrobiłam.
Spanikowana ręcznie przez Fille Zille usunęłam tego moda, ale nic nie dało ;(

W panelu z CBA znalazłam
Przywróć bazę z backupu
Przywracanie danych z backupu jest niebezpieczne dla Twoich danych. Użyj tej opcji tylko w ostateczności! Upewnij się, że masz utworzonego użytkownika bazy danych. Przed tą operacją lepiej zmień hasło do SQLa. Jak długo potrwa przywracanie z backupu zależy od wielkości bazy i obciążenia serwera.
Data backupu: nie wiadomo kiedy ostatnio zrobiono backup bazy


Czy to jeszcze bardziej niczego nie zepsuje?

I czy cokolwiek da jeżeli robiłam kopię zapasową przez panel admina strony?

CodeColon Select All Code

if (!empty($_GET['style']) && $auth->acl_get('a_styles') && !defined('ADMIN_START'))
        {
            global $SID, $_EXTRA_URL;

            $style = request_var('style', 0);
            $SID .= '&style=' . $style;
            $_EXTRA_URL = array('style=' . $style);
        }
        else
        
{
            // Set up style
//-- mod: Prime Quick Style -------------------------------------------------//
            include($phpbb_root_path . 'includes/prime_quick_style.' . $phpEx);
            $prime_quick_style->set_guest_style($style);
//-- end: Prime Quick Style -------------------------------------------------//
            $style = ($style) ? $style : ((!$config['override_user_style']) ? $this->data['user_style'] : $config['default_style']);
        }

 



To znajduje się w 1630 linijce

Edit.

Musiałam wyciąć kilka wierszy z dwóch plików, tam gdzie wskazywało i działa :)


Ale i tak mam pytanie, czy jak coś źle pójdzie, to czy przez panel CBA będę mogła jakoś przywrócić dane? Jak je tam zapisać?

I przy próbie robienia kopii bazy danych przez panel admin strony wyskakuje mi zazwyczaj błąd, przez co baza niecałkowicie się zapisuje, da radę coś na to poradzić?
Venite
Obsługa CBA
Posty: 3196
Rejestracja: 18 lut 2011, 08:01:57
Reputacja: 43
Lokalizacja: Kędzierzyn-Koźle
Płeć: Mężczyzna
User Agent: Opera Windows 1440x900

Re: Przywracanie kopii zapasowej

Postautor: Venite » 13 sie 2013, 11:50:07

Ian WroteColonfailed to open stream: No such file or directory

Co oznacza, że nie może czegoś otworzyć, bo brakuje mu pliku /includes/prime_quick_style.php. Sprawdź na ftp, czy w folderze includes posiadasz plik prime_quick_style.php?
Czy wiesz, że:
  • W Panelu CBA w sekcji "wsparcie" jest dedykowany system ticketów (obsługi technicznej)
  • Odpowiadamy na Forum oraz na adres mailowy obsluga(malpa)cba.pl
  • Jesteśmy również na Facebooku! Znajdź nas na facebook.com/hostingcba | cba.pl
W czym jeszcze możemy pomóc?
Ian
Posty: 23
Rejestracja: 22 lip 2013, 03:10:02
Reputacja: 0
Strona na CBA.pl: hungrybutterfly.y0.pl/phpbb3
Płeć: Niewybrana
User Agent: Chrome Windows 1366x768

Re: Przywracanie kopii zapasowej

Postautor: Ian » 13 sie 2013, 17:55:41

Już tamto naprawiłam, po prostu całość usunęłam, jednak nie będę się bawić w dodawanie modów.
Teraz mam ciut inny problem, jak wcześniej nie było problemu z dodawaniem zdjęć do postu z własnego komputera, tak teraz nie wchodzą. Dlaczego tak się może dziać?
Awatar użytkownika
DeaDriam
Posty: 4023
Rejestracja: 04 lip 2011, 14:00:40
Reputacja: 123
Lokalizacja: Möglingen
Płeć: Mężczyzna
User Agent: Firefox Windows 1024x768
Kontakt:

Re: Przywracanie kopii zapasowej

Postautor: DeaDriam » 13 sie 2013, 18:55:18

a jest jakis komunikat?
_____________________________________________________
Nie badz pijawka-znalazles rozwiazanie problemu..podziel sie na forum!
----------------------------------------------------------------------------
SmacznY WordpresS>> http://www.przepisyzgarnka.pl <<
Ian
Posty: 23
Rejestracja: 22 lip 2013, 03:10:02
Reputacja: 0
Strona na CBA.pl: hungrybutterfly.y0.pl/phpbb3
Płeć: Niewybrana
User Agent: Chrome Windows 1366x768

Re: Przywracanie kopii zapasowej

Postautor: Ian » 14 sie 2013, 00:19:12

Nie, wybieram plik, dodaję go, wtedy wyskakuje okienko, że plik jest dodawany. Piszę cokolwiek jako post i jedynie to się wyświetla. Jakby w ogóle obrazek się nie dodał. Jednak wyżej mam opcję: Załączniki: wstaw tekst - i z listy rozwijanej wybieram to co wrzuciłam i w dodanym poście pojawia się informacja jako prawdopodobnie podpis.

I wszystkie te obrazki, które były dodane wcześniej w ten sam sposób mają pokazaną tylko uszkodzoną ikonkę;/

Wróć do „Fora phpBB”

Kto jest online

Użytkownicy przeglądający to forum: Exabot [Bot] i 2 gości